В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Annna987
Annna987
23.08.2020 18:07 •  Информатика

Вданном массиве чисел найдите среднее арифметическое положительных элементов массива. составить программу для pascal abc

Показать ответ
Ответ:
vfhbz2000
vfhbz2000
08.10.2020 06:42
var    
     arr : array[1..99] of integer;
     N, s, k : integer;
begin
    read(N);
    for var i := 1 to N do begin
        arr[i] := random(-10, 10);
        writeln(arr[i]);
        if arr[i] > 0 then begin
            s += arr[i];
            k += 1;
        end
    end;
    writeln(s/k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота