В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
maksimys
maksimys
07.04.2023 23:01 •  Информатика

Весь интеренет облазила, но не нашла ничего путного, все имеющиеся программы не работают или составлены неправильно. используя все цифры от 1 до 9 по одному разу в различных комбинациях и операции сложения и вычитания, получить в сумме 100. надо написать программу на pascal.

Показать ответ
Ответ:
ответ:
А) БАГВ
Б) БВГА
Объяснение:
Ip адрес состоит из 4-х чисел, разделённых точками, каждое из чисел должно находиться в диапазоне от 0 до 255. =>
А)
Начинаем с [2.17] после [17] мы должны поставить ещё число либо это будет концом ip адреса, ищем то, что мы могли бы поставить после [2.17 16] - не подходит т.к. получится [1716], а это больше 255, [.65] тоже не подходит по этой же причине. Остаётся только [8.121] подставляем [2.17/8.121] получается [178] - это число находится в диапазоне от 0 до 255 оставляем так. Нам остаётся подставить ещё 2 фрагмента. Берём [.65] и подставляем в начало [.65/2.178.121] полуяви число [.652] оно не подходит т.к. больше 255, значит подставляем [.65] в конец и получаем [2.178.121.65] в конце ip адреса не обязательно должно стоять 4-х значное число. У нас осталось [16] подставляем в начало и получаем [162.178.121.65] это будет готовым ip адресом.
0,0(0 оценок)
Ответ:
mrpixkaGogar
mrpixkaGogar
17.05.2022 19:48
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=4;
  var xp:=new real[n];
  var yp:=new real[n];
  Writeln('Введите парами координаты четырех вершин');
  for var i:=0 to n-1 do Read(xp[i],yp[i]);
  var (x,y):=ReadReal2('Введите координаты точки:');
  var (i,j,c):=(0,n-1,False);
  while i<n do begin
    if ((yp[i]<=y) and (y<yp[j]) or (yp[j]<=y) and (y<yp [i]))
      and (x<(xp[j]-xp[i])*(y-yp[i])/(yp[j]-yp[i])+xp[i]) then c:=not c;
    j:=i; i+=1;
    end;
  if c then Writeln('Внутри')
  else Writeln('Не внутри')
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота