В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Лиопольд
Лиопольд
16.03.2020 03:42 •  Информатика

Вфайле input.txt имеются следующие записи: 8 18 23 7 13 27 33. нужно составить программу,которая определяет среднее арифметическое чисел файле input.txt. и записывает ответ файл output.txt. первое число файле input.txt указывать на количество чисел, следующих за ним. т.е(нужно 18+23+7+13+27+33 поделить на 6)

Показать ответ
Ответ:
Kot7476
Kot7476
06.10.2020 09:30
Немного непонятно, как 8 может указывать на то, что дальше будет 6 чисел.

python 3:
with open("input.txt") as f:
    numbers = list(map(int, f.read().split()))[1:]
    print(sum(numbers)/len(numbers))

PascalABC.NET 3.2:
begin
  var f := openread('input.txt');
  var n := readinteger(f);
  var sum := 0;
  for var i := 1 to n do
    sum += readinteger(f);
  write(sum / n);
end.
0,0(0 оценок)
Ответ:
2йошник
2йошник
06.10.2020 09:30
В такой постановке задача решается до смешного просто

// PascalABC.NET 3.2, сборка 1439 от 09.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln(ReadAllText('input.txt').ToIntegers.Skip(1).Average:0:4)
end.

Пример (для приведенных в задании данных)
20.1667
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота