В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Gagarinaa
Gagarinaa
10.10.2022 13:02 •  Информатика

Вфайле в столбик записаны целые числа. напишите программу, которая определяет количество пар соседних чисел таких, что предыдущее число меньше последующего, и выводит результат в конец исходного файла.

Показать ответ
Ответ:
Vlad44kostroma4
Vlad44kostroma4
05.10.2020 01:09
//Dev-C++ 5.11 (C)

#include <stdio.h>

int main(void)
 {FILE* f;
 int counter=0,pre,next,b=1;
 f=fopen("input.txt","r");
 fscanf(f,"%d",&pre);
 if (feof(f))
  b=0;
 else
  fscanf(f,"%d",&next);
 while (!(feof(f)) && b)
  {if(pre<next)
   counter++;
  pre=next;
  fscanf(f,"%d",&next);}
 if(pre<next)
   counter++;
 fclose(f);
 f=fopen("input.txt","a");
 fprintf(f,"\n%d",counter);
 fclose(f);
 return 0;}

Пример содержимого input.txt до работы программы:
12
123124124
2132134
12412
123123312
12
12345
Пример содержимого input.txt после работы программы:
12
123124124
2132134
12412
123123312
12
12345
3
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота