В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Sa6ok1
Sa6ok1
21.10.2022 11:49 •  Информатика

Вкладчик внес в сберкассу x рублей. написать программу,вычисляющую,сколько денег будет у него через n лет. кол-во денег каждый год увеличивается на 3 % по отношению к предыдущему году.

Показать ответ
Ответ:
121517
121517
28.05.2020 00:30

program test;
var years: integer; contribution: real;
begin
   write('Enter the contribution sum: ');
   readln(contribution);
   write('Enter the number of years: ');
   readln(years);

   while years <> 0 do
   begin
      contribution:=contribution+(contribution / 100 * 3);
      years:=years-1;
   end;

   writeln(contribution:0:2, ' rub');

   readln;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота