В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Naruto7xokage
Naruto7xokage
22.05.2020 00:23 •  Информатика

Вклассе 20 учеников писали диктант по языку.напишите программу(на паскале)подсчитывающая количество полученных 2,3,4,5.

Показать ответ
Ответ:
nagibala09Никичан
nagibala09Никичан
24.09.2020 07:50
Const n = 20;
var rez:array[2..5] of integer;
i,a:integer;
begin
  for i:=1 to n do begin
    write(i,' ученик получил ');
    readln(a);
    inc(rez[a]);
  end;
  writeln;
  for i:=2 to 5 do
    writeln('Оценку ',i,' получили ',rez[i]);  
end.

Тестовое решение:
1 ученик получил 3
2 ученик получил 4
3 ученик получил 3
4 ученик получил 5
5 ученик получил 2
6 ученик получил 2
7 ученик получил 3
8 ученик получил 4
9 ученик получил 5
10 ученик получил 4
11 ученик получил 2
12 ученик получил 3
13 ученик получил 3
14 ученик получил 4
15 ученик получил 5
16 ученик получил 5
17 ученик получил 3
18 ученик получил 5
19 ученик получил 4
20 ученик получил 4

Оценку 2 получили 3
Оценку 3 получили 6
Оценку 4 получили 6
Оценку 5 получили 5
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота