Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
макспростомакс1
01.12.2020 16:44 •
Информатика
Вмассиве хранится информация о стоимости товаров. составьте программу, которая определяет стоимость самого дешёвого (дорогого) товара и его индекс
Показать ответ
Ответ:
nynsikram
04.10.2020 02:23
#include <iostream>
int main(){ const int kol_tov = 20;
int sbol = 0; int sbol_index = 0; int smal = 0; int smal_index = 0;
int massiv[kol_tov] = { 12, 150, 1230, 332, 531, 1321, 32313, 123123, 123434, 4844, 84847, 48816, 181684, 181, 78616, 81141, 1894, 18974, 91234, 21239 };
smal = massiv[1];
for (int i = 0; i < kol_tov; i++) { if (massiv[i] > sbol) { sbol = massiv[i]; sbol_index = i + 1; } if (massiv[i] < smal) { smal = massiv[i]; smal_index = i + 1; } }
std::cout << "Samoe dorogoe: " << sbol << std::endl << "Samoe deshevoe: " << smal << std::endl << "Index dorogogo: " << sbol_index << std::endl << "Index deshevogo: " << smal_index << std::endl; system("PAUSE");}
0,0
(0 оценок)
Популярные вопросы: Информатика
kristina160225
06.03.2020 17:19
Расставь команды на схеме алгоритма собери яблоки вместо знаков ? впиши слова да и нет...
SophiaSaliuk
02.02.2022 23:48
Начертите на бланке структуру базы данных «картинная галерея», содержащую сведения о полотнах художников. укажите необходимые имена полей и их типы данных. задайте ключевое поле....
GreenApelsin
26.10.2020 23:25
Даны числа в диапазоне от а до б,вывести все кратные числа к найти из сумму и произведения...
TheSpace
09.03.2021 16:09
Скільки від ємних і додатних значень має функція. на екран вивести окремо додатні і окремо від ємні значення функції. ...
daniil2zhuravlev
04.06.2020 18:46
Какое логическое выражение равносильно выражению ¬(¬a \/ b) \/ ¬c 1) (a /\ ¬b) \/ ¬c 2) ¬a \/ b \/ ¬c 3) a \/ ¬b \/ ¬c 4) (¬a /\ b) \/ ¬c...
Вsеzнaйkа
16.02.2022 13:57
Интформатика 7 класс составить комманду...
REDUCE007
04.06.2020 18:46
Дан двумерный массив размерностью n*m. уменьшить в два раза все четные элементы массива.( сделать программу на паскале)....
Polinaqqq
10.08.2020 05:10
Створіть інформаційну модель святкування дня народження. Форму подання моделі виберіть самостійно Кто ответит правильно поставлю 5 звёзд...
gleb090902
25.08.2021 08:23
Задача по информатике! Решить на любом языке программирования...
Nastia2k
20.08.2020 18:18
Запишіть рівняння реакції взаємодії фосфор (V) оксиду з водою....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
int main(){ const int kol_tov = 20;
int sbol = 0; int sbol_index = 0; int smal = 0; int smal_index = 0;
int massiv[kol_tov] = { 12, 150, 1230, 332, 531, 1321, 32313, 123123, 123434, 4844, 84847, 48816, 181684, 181, 78616, 81141, 1894, 18974, 91234, 21239 };
smal = massiv[1];
for (int i = 0; i < kol_tov; i++) { if (massiv[i] > sbol) { sbol = massiv[i]; sbol_index = i + 1; } if (massiv[i] < smal) { smal = massiv[i]; smal_index = i + 1; } }
std::cout << "Samoe dorogoe: " << sbol << std::endl << "Samoe deshevoe: " << smal << std::endl << "Index dorogogo: " << sbol_index << std::endl << "Index deshevogo: " << smal_index << std::endl; system("PAUSE");}