В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Вмассиве хранятся сведения о количестве осадков(в мм),выпадавших ежедневно в сентябре.составьте программу,которая подсчитывает количество дождливых дней (h [i] > 0) люди ! надо,кому не

Показать ответ
Ответ:
italyyyy
italyyyy
04.10.2020 19:19
Const N = 30; // Количетсво дней
var
i,count:integer;
h: array [1..N] of integer;
begin
count:=0;
writeln('Введите количество осадков');
for i:=1 to N do
read(h[i]);
for i:=1 to N do
if h[i]>0 then
count:=count+1;
writeln('Количество дождливых дней ', count)
end.

В первой строке указываем количество дней. Это константа N
Далее объявляем, что переменная count равна 0. В этой переменной мы будем хранить количество дней с осадками.
Далее мы вводим с клавиатуры 30 чисел, показывающих осадки.
Потом мы проверяем, если число в массиве больше нуля, то мы увеличиваем count на единицу. Тоесть прибавляем +1 день с осадками.
В конце выводим количество дней с осадками
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота