В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
пмнирче
пмнирче
28.09.2020 15:13 •  Информатика

Вмассиве из 10 целых чисел подсчитать сумму элементов, стоящих правее минимального.написать программу на языке паскаль., .

Показать ответ
Ответ:
дима2872
дима2872
22.06.2020 15:04
Var a: array [1..10] of Integer;
    i, min, sum: integer;
begin
     for i := 1 to 10 do
     begin
          a[i] := random(50);
          writeln('[', i, '] => ', a[i]);
     end;
          min := a[1];
     for i := 2 to 10 do
          if (min > a[i]) then min := a[i];
     i := 1;
     while ((i <= 10) and (a[i] <> min)) do
     begin
           sum := sum + a[i];
           inc(i);
     end;
     writeln(sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота