Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
ilkasb
08.06.2020 14:15 •
Информатика
Вмассиве, состоящем из 10-ти произвольных чисел, вычислить полусумму элементов с нечетными индексами (а[1]+ a[3]+ a[5]+
Показать ответ
Ответ:
arti52
21.06.2020 14:14
#include <stdio.h>
#include <conio.h>
#include <ctime>
#include <stdlib.h>
main()
{
int b,s[10],k=10,i;
srand(time(0));
for (i=0;i<k;i++){
s[i]=rand()%120-60;
printf("%3d",s[i]);
}
b=0;
for (i=0;i<k;i++){
if ((i%2)>0){
b+=s[i];
}
}
b=b/2;
printf ("\n%d",b);
getch();
}
0,0
(0 оценок)
Популярные вопросы: Информатика
ХозяинНосочков
25.05.2021 00:36
Написать программу в паскале которая распечатывает таблицу умножения на 2...
vitaliysv200313
06.01.2021 20:41
Опишите систему хранения файлов на диске...
oksukbaevak
02.12.2022 02:30
Начало испытания вход выход 1. выписать 3-ю букву входного слова. кумир мука 2. выписать 2-ю букву входного слова. ракета кара метр тема мудрость дума конец выполни алгоритм для...
erikterik
13.11.2021 17:22
10. Выбери оператор цикла с известным числом повторений в руthon ( : 1) while for il elif...
лала4647
09.03.2021 18:52
Кылтык создерды колданып бос орындарды толтырыныз...
леракулдошина
08.01.2023 01:51
Даны три числа x y z вычислить квадратные корни тех из них значения которых положительны и корни кубические тех значения которых отрицательны...
костров1
30.10.2020 22:00
Проанализировать представленый код, исправить логические и синтаксические ошибки. опеределить, какая стояла перед программистом. добавить комментарий к каждой строчке программы,поясняющий,...
Dimo558
20.06.2020 15:45
Впяти тестах ученик получил оценки.составьте программу для вычисления среднего ...
joker231341
12.09.2022 13:46
Найдите координаты точки С, если В середина отрезка АС даны точки А(21;15;-8) В(6; 4,2 ;1)даны координаты середины отрезка АВ (13,5; 9,6 ; -3,5)...
silinskay
05.12.2021 04:09
Кокотой кайсы жердин ханы болгон...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <conio.h>
#include <ctime>
#include <stdlib.h>
main()
{
int b,s[10],k=10,i;
srand(time(0));
for (i=0;i<k;i++){
s[i]=rand()%120-60;
printf("%3d",s[i]);
}
b=0;
for (i=0;i<k;i++){
if ((i%2)>0){
b+=s[i];
}
}
b=b/2;
printf ("\n%d",b);
getch();
}