В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Nematzoda1999
Nematzoda1999
16.01.2022 06:36 •  Информатика

Вмассиве состоящим из 30 целых чисел вводят оценки 10 учениов ,нужно вывести на экран оценки в виде таблицы: в первом столбце номер ученика,во втором его оценки.написать программу паскаль

Показать ответ
Ответ:
bar569
bar569
24.05.2020 04:07

var a:array[1..2,1..30] of integer;
i,j:integer;
Begin
    for i:= 1 to 30 do begin
        writeln('Введите номер ученика:');
        read(a[1,i]);
        writeln('Введите оценку:');
        read(a[2,i]);
    end;
    
    for i:= 1 to 10 do begin
      writeln(i:2,' - ');
        for j:= 1 to 30
          if a[1,j]=i then
                write(a[2,i],' ');
    end;        
    readkey;
End.   

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота