Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
NJazira11
11.01.2023 09:26 •
Информатика
Вмассиве y состоящем из 12 целых чисел определить среднее арифметическое тех из них которые являются четными
Показать ответ
Ответ:
DarinaKimovsk
14.07.2020 13:25
Var y: array[1..12] of integer;
i,k:integer; s:real;
begin
for i:=1 to 12 do
read (y[i]);
for i:=1 to 12 do
if y[i] mod 2=0 then
begin
s:=s+y[i];
k:=k+1;
end;
s:=s/k;
write (s:5:1);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
alaska122
25.10.2020 14:11
Дан массив целых чисел. Количество за с клавиатуры. Найти: 1) максимальный элемент массива и его номер, при условии, что все элементы различны; 2) минимальный размер...
ВаняиМаша
19.10.2020 21:32
Алгоритм создания дивана в скетч апе...
ILiveYou
10.09.2021 01:24
Нужно написать функцию bubble_sort() в которую в качестве аргумента поступает массив. Функция должна отсортировать поступивший массив методом сортировки пузырьком...
rasputniya
10.05.2020 04:02
Как сгруппированы элементы обработки текста...
Andry211208
22.06.2022 23:16
1. Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 4. Программа получает на вход количество чисел в последовательности,...
stenolaz19
04.01.2023 08:57
Приведите примеры псевдо кодов...
llun
05.05.2020 08:57
Найдите пары: науки (буква) и изучаемые ими объекты (цифра) а) астрономия б) в) биология г) д) технология е) ж) информатика человечества 2) количественные отношения...
tanyagorelik
06.04.2021 00:27
Составьте блок схему алгоритма вычисления значения функции...
АринаКузьмичева
26.02.2021 14:22
Назовите две программы для 3D моделирования?...
Sima121
01.04.2020 20:28
Слайд, який існує в презентації, проте НЕ демонструється при показі називають...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
i,k:integer; s:real;
begin
for i:=1 to 12 do
read (y[i]);
for i:=1 to 12 do
if y[i] mod 2=0 then
begin
s:=s+y[i];
k:=k+1;
end;
s:=s/k;
write (s:5:1);
end.