В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Во В программе используется одномерный целочисленный массив А с индексами от 0 до 9. Значения элементов равны 8, 4, 3, 0,7, 2, 1, 5, 9, 6 соответственно, т.е.
A[0] = 8, А[1] = 4 и т.д. Определите значение переменной s после выполнения следующего фрагмента программы:
s:= 0;
for j:= 0 to 9 do
if All <= 4 then
S = j;
Введите правильный вариант ответа:​

Показать ответ
Ответ:
kilbas1ggttyi
kilbas1ggttyi
07.04.2020 12:27

Program maximal;

const

nmax=100;

var

a:array[1..nmax] of integer;

N,i,max:integer;

begin

readln(N);

max:=0;

for i:=1 to N do

 begin

   read(a[i]);

   if max<a[i] then

     max:=a[i];

end;

write(max);

end.



2) Program B;

    const

nmax=100;

var

a:array[1..nmax] of integer;

N,i,z:integer;

begin

readln(N);

z:=0;

for i:=1 to N do

 begin

   read(a[i]);

   if a[i]>0 then

       write(a[i],' ');

    if a[i]=0 then

       z:=z+1;

end;

writeln();

for i:=1 to N do

   begin

      if a[i]<0 then

        write(a[i],' ');

  end;

writeln();

for i:=1 to z do

   write('0',' ')

end.

0,0(0 оценок)
Ответ:
Dogi2008
Dogi2008
27.02.2023 16:00
Const   n = 50; // количество чиселvar   k: array [1..n] of integer;   i, j, n1, n2, minr, a, b: integer; begin   writeln(n, ' ', ': d');   a : = random(1000);   b : = random(1000);   minr : = 10000;   for i : = 1 to n do       k[i] : = a + random(b);   for i : = 1 to n do       for j : = 1 to n do           if ((abs(k[i] - k[j])) < minr) and (k[i] < > k[j]) then           begin               minr : = abs(k[i] - k[j]);               n1 : = i;               n2 : = j;           end;   writeln(n1, ' ', n2); end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота