В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Sashka15081
Sashka15081
13.08.2021 22:17 •  Информатика

Водномерном массиве а(к) хранятся результаты социологического опроса, напишите программу для подсчета кол-ва результатов отклоняющихся от среднего не более чем на 7% кол-во людей: 200. [0; 100]случайные числа( которые ставят люди). программа должна быть написанна для visual basic.

Показать ответ
Ответ:
Алёксейudfih
Алёксейudfih
11.06.2020 04:05

using System;
using System.Linq;

namespace Interesting {
    class Program {
        static void Main(params int[] a) {
            int n = 0;
            foreach (int i in a) {
                n += (Math.Abs(i - a.Average()) / 100 <= 0.07) ? 1 : 0;
            }
            Console.WriteLine(n);
        }
    }
}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота