Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
dancecowerbts
06.01.2021 20:45 •
Информатика
Водномерном массиве а подсчитать число положительных элементов, имеющих четный индекс. отрицательные элементы массива заменить нулями (в паскале)
Показать ответ
Ответ:
Азот11
19.06.2020 04:57
Var a: array [1..100] of real;
n, i, kol: integer;
begin
readln(n);
for i := 1 to n do
read(a[i]);
kol := 0;
for i := 1 to n do begin
if (a[i] > 0)and(i mod 2 = 0)
then kol := kol + 1;
if a[i] < 0
then a[i] :=0;
end;
writeln(kol);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
KKnoneTT
08.01.2021 20:00
Гайс решить номер 11 по информатике >...
Natasha1678
30.05.2022 05:18
Составить программу 1)найти сумму всех элементов массива (1до10) random. 2)сформировать массив из положительных и отрицательных элементов от -10 до 30.найти кол-во положит...
коля856
05.03.2023 15:57
1. В ячейке третьего листа B4 вычислите сумму чисел ячейки СЗ первого листа и ячейки D6 второго листа.2. Оценки учащихся по предметам история, химия, физика и математикасохраните...
LindSayWoW
25.12.2021 04:48
Перечислите функции служебных программ...
dasyakim
02.01.2023 18:26
Написал код, но выходные данные всегда одинаковы, почему? const randomNumber = Math.floor(Math.random() * 100); switch(randomNumber) { case (randomNumber 20) : console.log(...
03021971
04.09.2020 09:09
2 в равнобокой трапеции один из углов равен 120°, диагональ трапеции образует с боковойстороной утол 90°. Найдите основания трапеции,боковая сторона равна 6 смпосогите...
polinakarpova4
04.09.2020 09:09
Составьте 5 СПП из 3 простых предложений...
Chumaeva79
21.08.2022 21:48
Ташымалданбаган сөзду белгилениз?а) айры. б)така в)чана. г)жаан...
elizavetamalik1
15.01.2021 03:45
ДА Написать текст- рассуждение на тему: «Казахстан является сухопутной страной?» ( 90-100 слов)....
vikysik927
11.09.2021 22:08
Көпбұрыштың диогоналі дегеніміз не?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
n, i, kol: integer;
begin
readln(n);
for i := 1 to n do
read(a[i]);
kol := 0;
for i := 1 to n do begin
if (a[i] > 0)and(i mod 2 = 0)
then kol := kol + 1;
if a[i] < 0
then a[i] :=0;
end;
writeln(kol);
end.