В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Вопрос 1 Напишите программу на языке Python, которая получает
с клавиатуры натуральное число и определяет
количество цифр в этом числе,
Введите ответ в произвольной форме:
,

Показать ответ
Ответ:
olyascochilyas
olyascochilyas
18.04.2021 22:50

Відповідь:

N=int(input())

c=0

while N>0:

   N=N//10

   c=c+1

print(c)

Пояснення:

0,0(0 оценок)
Ответ:
lisopat
lisopat
18.04.2021 22:50

i=int(input())

if i<0:

   print(len(str(i))-1)

else:

   print(len(str(i)))

Объяснение:

проверяем положительное ли число, если нет, то из длины символов вычитаем 1 (т.к. у нас "-" считается за символ), иначе выводим просто длину

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота