В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
666SmEtAnKa666
666SmEtAnKa666
08.07.2021 11:00 •  Информатика

Впаскале: 1.составить функцию и процедуру, которая определяет сумму всех чисел от 1 до n. 2.составить программу, которая определяет нод и нок двух чисел.

Показать ответ
Ответ:
nataxasan1984
nataxasan1984
30.06.2020 15:21
1)
program gt;
var n,s:integer;
procedure  summa(n:integer;var s:integer);
begin
s:=((n+1)*n)div 2;
writeln(s);
end;
begin
read(n);
summa(n,s);
end.
1.2)
program gt2;
var n,s:integer;
function summa(n:integer):integer;
var s:integer;
begin
s:=((n+1)*n)div 2;
summa:=s;
end;
begin
read(n);
s:=summa(n);
writeln(s);
end.
2)program gt;
label 3,9;
var m,n,q,r,a,b:longint;
begin
read(m,n);
a:=m;b:=n;
3:
q:=m div n;
r:=m mod n;
if (r=0)then goto 9;
m:=n;
n:=r;
goto 3;
9:
m:=(a*b)div n;
writeln('НОД=',n);
writeln('NOK=',m);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота