В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
снежана195
снежана195
12.08.2021 17:12 •  Информатика

Впаскале, через case of составить программу для начисления зарплаты согласно следующему правилу: если стаж работы сотрудника менее 5 лет, то зарплата 50$., при стаже работы от 5 до 15 лет — 100$., при стаже свыше 15 лет зарплата повышается с каждым годом на 10$, превышающем 30 лет она составляет 300$

Показать ответ
Ответ:
Зара7878
Зара7878
09.10.2020 21:25

var

old:integer;

begin

writeln('Введите стаж');

readln(old);

case old of

0..4: writeln('50$');

5..15: writeln('100$');

16..30: writeln(100+(old mod 15)*10);

31..100: writeln('300$');

end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота