В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
radmila85
radmila85
23.12.2020 02:11 •  Информатика

Впаскале и только в паскале. 1)дан массив десяти целых чисел напишите программу которая выводит элементы массива в порядке не убывания. 2)дан массив десяти целых чисел напишите программу которая выводит элементы массива в порядке убывания , а также выводит количество перестановок. 3)дан массив десяти целых чисел. найти медиану числового ряда. 4) дан массив десяти целых чисел выведите минимальное число массива оканчиговающегося на 4 5) дан массив десяти целых чисел напишите программу которая выводит на экран на экран максимальное число кратное 5.

Показать ответ
Ответ:
Ffffffsusjbshjxj
Ffffffsusjbshjxj
07.10.2020 09:10
 1) 
var i,n,k:integer;
 a:array[1..10] of integer;
begin
 for i:=1 to 10 do
  read(a[i]);
 writeln;
 for i:=10 downto 1 do
  write(a[i],' ');
 readln;
 readln
end.
3)
var i,n,k:integer;
a:array[1..10] of integer;
begin
 for i:=1 to 10 do
  read(a[i]);
 writeln;
 writeln((a[5]+a[6])/2:0:2);
 readln;
 readln
end.
4)
var i,n,k,min:integer;
a:array[1..10] of integer;
begin
 for i:=1 to 10 do
  begin
   read(a[i]);
   if (a[i] mod 10=4) or (a[i] mod 10=-4)
    then min:=a[i];

 for i:=1 to 10 do
   if ((a[i] mod 10=4) or (a[i] mod 10=-4)) and (a[i]<min)
    then min:=a[i];
 writeln(min);
end.

5)
 var i,n,k,max:integer;
a:array[1..10] of integer;
begin
 max:=0;
 for i:=1 to 10 do
  begin
   read(a[i]);
   if (a[i] mod 5=0) and (a[i]>max)
    then max:=a[i];
  end;
 writeln(max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота