В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
lizamalaya2012
lizamalaya2012
17.12.2020 12:35 •  Информатика

Впаскале. написать программу, которая вычисляет среднее арифметическое вводимой с клавиатуры последовательности действительных чисел. количество чисел должно задаваться во время работы программы. ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделено полу жирным шрифтом). вычисления среднего арифметического последовательности действительных чисел. найдите количество чисел последовательности -> 15. введите последовательность. после ввода каждого числа нажмите enter. -> 5.4 -> 7.8 -> 3.0 -> 1.5 -> 2.3 среднее арифметическое введенной последовательности: 4.00 для завершения работы программы нажмите enter.

Показать ответ
Ответ:
Лилька120
Лилька120
17.07.2020 18:17
Uses
  Crt;
var
  i,n:integer;
  a,s:real;
begin
  Writeln('Вычисление среднего арифметического');
  Writeln('последовательности действительных чисел');
  Write('Введите количество чисел последовательности ->');
  Readln(n);
  Writeln('Введите последовательность. После ввода каждого числа нажмите Enter');
  s:=0;
  for i:=1 to n do
  begin
    Read(a);
    s:=s+a
  end;
  Writeln('Среднее арифметическое введенной последовательности: ',s/n);
  Write('Для завершения работы программы нажмите Enter');
  Readkey
end.

Тестовое решение:
Вычисление среднего арифметического
последовательности действительных чисел
Введите количество чисел последовательности ->5
Введите последовательность. После ввода каждого числа нажмите Enter
5.4
7.8
3.0
1.5
2.3
Среднее арифметическое введенной последовательности: 4
Для завершения работы программы нажмите Enter

Для версии Pascal.ABC.Net:
var
  i,n:integer;
  a,s:real;
begin
  Writeln('Вычисление среднего арифметического');
  Writeln('последовательности действительных чисел');
  Write('Введите количество чисел последовательности ->');
  Readln(n);
  Writeln('Введите последовательность. После ввода каждого числа нажмите Enter');
  s:=0;
  for i:=1 to n do
  begin
    Read(a);
    s:=s+a
  end;
  Writeln('Среднее арифметическое введенной последовательности: ',s/n)
end.
 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота