В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Впаскале. пусть в массиве содержатся результаты измерений температуры воздуха за декабрь, которые проводились ежедневно. определите сколько дней в декабре температура была выше средней.

Показать ответ
Ответ:
sonya0013
sonya0013
13.06.2020 11:16

const d = 31;
var
  a: array[1..d] of integer;
  i, count, mdl: integer;
begin
  for i := 1 to d do begin
    a[i] := random(31);
    write(a[i], ' ');
    mdl := mdl + a[i];
  end;
  writeln;
  writeln('Средняя температура: ', (mdl / d):0:2);
  for i := 1 to d do
    if(a[i] > mdl / d) then inc(count);
  writeln('Дни, в которые температура была выше средней: ', count);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота