В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
skosachyov
skosachyov
11.02.2021 12:18 •  Информатика

Впаскале с repeat. составьте программу, которая выводит на экран сумму нечетных чисел от 36 до 66.

Показать ответ
Ответ:
ученик1443
ученик1443
17.09.2020 18:50
Begin
  Writeln(((65+37)*((65-37) div 2 +1)) div 2);
end.

Или более универсально:
Var A,B : Integer;
Begin
  Readln(A,B);
  Inc(A,Ord(not Odd(A)));
  Dec(B,Ord(not Odd(B)));
  Writeln(((B+A)*((B-A) div 2 +1)) div 2);
end.

А если строго по заданию, то так:
Var S,i : Integer;
Begin
  s:=0; i:=37;
  Repeat
    s:=s+i;
    Inc(i,2);
  Until i>65;
  Writeln(s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота