В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
вика3878
вика3878
25.08.2022 23:36 •  Информатика

Впаскале. составить программу, по которой компьютер находит произведение нечетных чисел, начиная с единицы, и до тех пор, пока на вопрос, задаваемый после каждого шага вычислений: «продолжить вычисления? (д/н)», отвечают ‘д’.

Показать ответ
Ответ:
sir58k
sir58k
02.10.2020 14:41
Var  a:longint;  b:integer;  s:string;  
begin 
 readln(s); 
 a:=1;  b:=1; 
 repeat   
  writeln('Продолжить вычисления? (Д/Н)');   
  b:=b+2;   
  a:=a*b;   
  readln(s); 
 until (s<>'Д'); 
 write(a);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота