Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
kapov2017p0aak6
23.08.2022 16:54 •
Информатика
Впаскале. в массиве хранится информация о стоимости каждого из 50 марок легковых автомобилей определить, сколько стоит самый дорогой автомобиль.
Показать ответ
Ответ:
severin4568
06.10.2020 09:10
Const
N = 50;
Var
M:array[1..N] of longint;
i,Max:integer;
Begin
Randomize;
WriteLn('Цены(в рублях): ');
Max:=1;
For i:= 1 to N do
Begin
M[i]:=random(9900001)+100000;
WriteLn(M[i]);
if M[i] > M[Max] then Max:=i;
End;
WriteLn('Max = ',M[Max]);
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
Настечок
22.05.2020 18:45
Какое значение будет принимать переменная z после выполнения алгоритма: х:=512 y:=1024 если x вывод z...
casha23
22.03.2021 08:08
Только номер класс♥️♥️...
linali20041
07.02.2022 02:56
мне!(картинка к 3 заданию)1. Рассмотрим алфавит, состоящий из следующих символов: 0,1,2,3,4,5,6,7. Какова его мощность? * 1238102. Пользователь находился в каталоге Расписание....
komkov2
15.05.2020 11:33
2. Разработчик подготовил фоновое изображение для разработки программы.а) Укажите команду для установки фона игры.Б) Опишите действия разработчика для установки фонового...
ViollaK2704
10.08.2021 16:51
Можно ли изменить имя спрайта? *ОНельзяО) Можно только на русском языкеМожно только на английскомязыкеОт Можно...
benten2434
15.12.2022 03:25
Дано число x. Вычислить Y=x^10+2x^9 +3x^8...+10x+11 C++...
desna80
05.02.2023 09:07
Центральний об єкт на ментальній карті - це......
zoyasvet
11.06.2021 15:54
Статья, набранная на компьютере, содержит 16 страниц, на каждой странице 32 строки, в каждой строке 48 символов. Информационный объём статьи в этом варианте представления...
dilyara112005
02.05.2022 01:58
1)напишите программу которая вычисляет сумму квадратов первых n-натуральных чисел.2)вводится последовательность целых чисел. последовательность оканчивается нулём,вывести...
УмНиК4980
24.09.2020 02:51
Напишите все серверы, через которые проходит ваш пакет до сервера gо.gle.cоm, когда вы его открываете в браузере....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
N = 50;
Var
M:array[1..N] of longint;
i,Max:integer;
Begin
Randomize;
WriteLn('Цены(в рублях): ');
Max:=1;
For i:= 1 to N do
Begin
M[i]:=random(9900001)+100000;
WriteLn(M[i]);
if M[i] > M[Max] then Max:=i;
End;
WriteLn('Max = ',M[Max]);
End.