Все на языке бейсик
1. написать программу, которая 10 раз выводит на экран имя и фамилию.
2. написать программу, которая выводит на экран таблицу квадратов первых десяти целых положительных чисел.
рекомендуемый вид экрана во время работы программы:
таблица квадратов
- - - - - - - - - - - - - -
число квадратов
- - - - - - - - - - - - - -
1 1
2 4
3 9
4 16
5 25
- - - - - - - - - - - - - -
3. написать программу, которая вычисляет сумму первых n целых положительных чисел. количество суммируемых чисел должно водиться во время работы программы.
рекомендуемый вид экрана во время работы программы:
вычисление суммы положительных чисел.
введите количество суммируемых чисел = 20
сумма первых 20 положительных чисел равна 210.
2) 100001100 = 2^8 + 2^3 + 2^2 = 256 + 8 + 4 = 268
3) 137 = 10001001 (нужно число делить на 2, записывая остаток, и так до тех пор пока число уже нельзя будет делить, потом записываем остатки в обратном порядке)
137 / 2 = 68 ( остаток 1)
68 / 2 = 34 (остаток 0)
34 / 2 = 17 (остаток 0)
17 / 2 = 8 (остаток 1)
8 / 2 = 4 (0)
4 / 2 = 2 (0)
2 / 2 = 1 (0)
Теперь надо записать остатки в обратном порядке = 10001001
4) Как я понял 8 и 16 это систему счисления, если да то:
а)151 = 1 * 8^2 + 5 * 8^1 + 1 * 8^0 = 64 + 40 + 1 = 105
б) 2С = 2 * 16 + 12(С) = 32 + 12 = 44
ну блин как то так наверное
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('Введите текст, завершив его точкой:'+NewLine);
s:=s[:Pos('.',s)];
var k:=s.ToWords.Select(w->w.MatchValues('\b[A-ZА-ЯЁ][a-zа-яё]*\b'))
.Where(w->w.Count>0).Count;
Writeln('Найдено слов: ',k)
end.
Пример
Введите текст, завершив его точкой:
Карл у Клары украл кораллы Клара у Карла украла кларнет.
Найдено слов: 4
Примечание: Буквы латинского алфавита также обрабатываются.