Всем привет. У меня вопрос по поводу питона. Здесь комп. игра. В моём коде машина едет всё время в одном направлении, однако должна ехать в случайном. Рандом у меня есть. В чём проблема? И да, игра ещё не доделанная. VV КОД VV
import pygame
from random import choice
from random import randint
cordi2 = randint(10,250)
cordi = [10,130,250]
import time
WIDTH = 300
HEIGHT = 500
FPS = 60
WHITE = (255, 255, 255)
RED = (241, 58, 19)
PURPLE = (99,58,101)
BLACK = (0, 0, 0)
pygame.init()
clock = pygame.time.Clock()
screen = pygame.display.set_mode((WIDTH, HEIGHT))
x = 130
y = 410
y_enemy = 0 - 70
car = pygame.Rect(x,y,40,70)
position = randint(1,3)
if position == 1:
x_enemy = 10
elif position == 2:
x_enemy = 130
elif position == 3:
x_enemy = 250
car_img = pygame.image.load("car.bmp").convert()
car_enemy_img = pygame.image.load("carenemy.bmp").convert()
car_enemy = pygame.Rect(x_enemy,y_enemy,40,70)
SPEED = 2
running = True
while running:
screen.fill(WHITE)
for i in pygame.event.get():
if i.type == pygame.QUIT:
running = False
if i.type == pygame.KEYDOWN:
if i.key == pygame.K_LEFT:
if car.left > 10:
car.left -= 120
if i.key == pygame.K_RIGHT:
if car.left < 250:
car.left += 120
if car_enemy.top >= HEIGHT + 70:
if position == 1:
x_enemy = 10
elif position == 2:
x_enemy = 130
elif position == 3:
x_enemy = 250
SPEED += 1
position = randint(1,3)
car_enemy.top = 0 - 70
else:
car_enemy.top += SPEED
screen.blit(car_enemy_img, (car_enemy.left, car_enemy.top))
screen.blit(car_img, (car.left, car.top))
pygame.display.update()
clock.tick(FPS)
pygame.quit()
using System;
namespace ConsoleApplication55{ class Program { static void Main(string[] args) { link: Console.Write("Введите кол-во элементов числовой последовательности: "); int kol = Convert.ToInt32(Console.ReadLine()); if (kol > 100 || kol < 0) goto link; Random ran = new Random(); int[] array = new int[kol]; Console.WriteLine("\nПоследовательность чисел в строчку: "); for (int i = 0; i < array.Length; i++) { array[i] = ran.Next(1, 1000); Console.Write(array[i] + " "); } Console.Write("\n\nПоследовательность чисел, где каждое с новой строки:\n"); for (int i = 0; i < array.Length; i++) Console.Write(array[i] + "\n"); Console.ReadKey(); } }}
Смысл такой: ты делаешь массив, размер которого указываешь в начале, потом загружаешь него рандомные(случайные) числа с периодом от 1 до 1000. После этого выводишь с цикла for элементы с условием, что после каждого элемента будет перевод строки(в С# это "\n"), в Паскале это writeln и т.д.
Г) логика
2. Повествовательное предложение, в котором что-то утверждается или отрицается называется:
В) высказывание
3. Константа, которая обозначается «1» в алгебре логики называется:
В) истина
4. Какое из следующих высказываний являются истинным?
В) II + VI = VIII (2 + 6 = 8, записанное при римских чисел)
5. Объединение двух высказываний в одно с союза «и» называется:
Б) конъюнкция
6. Чему равно значение логического выражения (1v1)^(1v0)?
А) 1 ((1 v 1) ^ (1 v 0) = 1 ^ 1 = 1)
7. Что такое логика?
B) это наука о формах и законах человеческого мышления и, в частности, о законах доказательных рассуждений
8. Логической операцией не является:
A) логическое деление
9. Объединение двух высказываний в одно с оборота «если..., то..» называется:
Г) импликация
10. Таблица, содержащая все возможные значения логического выражения, называется:
Б) таблица истинности
11. Даны три высказывания:
А = (Наступила осень)
В = (Мы учимся в колледже)
С = (Мы решаем контрольную работу)
Напишите в виде формулы высказывание: «Наступила осень, мы учимся в колледже и решаем контрольную работу»
ABC
12. Придумайте ложное высказывание, соответствующее функции и постройте таблицу истинности для следующей функции:
Х=А+ВС
В ответе выписать комбинации А, В, С при которых Х – ложно.
Например, если A = (Скопье – столица Черногории), B = (Скопье – столица Македонии) и C = (Скопье – столица Эфиопии), то X = A + BC соответствует ложному высказыванию "Скопье – столица Черногории или Македонии и Эфиопии".
Таблица истинности:
A B C X
0 0 0 0
0 0 1 0
0 1 0 0 – случай из примера
0 1 1 1
1 0 0 1
1 0 1 1
1 1 0 1
1 1 1 1
X ложно при (A, B, C) = (0, 0, 0), (0, 0, 1), (0, 1, 0).