В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
iragav30
iragav30
11.06.2021 21:52 •  Информатика

Всем , сильно и нужна ваша !

1.дано слово: строка. написать программу, заменяющую букву т на к
2.написать программу, которая проверяет, является ли данный текст записью числа

Показать ответ
Ответ:
Animeshon
Animeshon
26.04.2021 00:54

Program msdos;
uses crt;
var
  r,sum: real;
  neg:integer;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  neg:=0;
  sum:=0;
  r:=1;
  writeln('Введите ненулевое число');
  writeln('(или введите 0 для конца последовательности) ');
  while r<>0 do
    begin
      write('Ввод:');  
      readln (r);
      if r<0 then neg:=neg+1;
      if r>0 then sum:=sum+r;
    end;
  writeln();
  writeln('Количество отрицательных чисел ',neg);
  writeln('Сумма положительных чисел ',sum);
end.

0,0(0 оценок)
Ответ:
kiranovm14
kiranovm14
07.01.2023 10:31

Проверено - работает на Паскаль АВС.

Кстати, похоже на какую-то ошибку в условии задачи: по формуле A(X,Y)=2X^2-Y^2 ни один элемент массива никогда не будет равен 0.


Program Lobu;
uses crt;
const n=2;
var
  a:array[1..n,1..n] of real;
  neg,sum: real;
  i,j:integer;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  neg:=0;
  sum:=0;
  for i:=1 to n do
    begin
      for j:=1 to n do
        begin
         a[i,j]:=2*i*i-j*j;
         write (a[i,j]:7:2);
         if a[i,j]<0 then neg:=neg+1;
         if a[i,j]>0 then sum:=sum+a[i,j];
         if a[i,j]=0 then writeln('Элемент А(',i,',',j,') равен 0');
        end;
      writeln();
    end;
  writeln();
  writeln('Количество отрицательных чисел ',neg);
  writeln('Сумма положительных чисел ',sum);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота