В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
minat2
minat2
22.08.2021 14:35 •  Информатика

Ввести целочисленный массив X(N), элементами которого являются числа из диапазона [-40..40]. Подсчитать сумму элементов массива кратных 3. Написать программу в C++.

Показать ответ
Ответ:
Neznayka56000
Neznayka56000
25.09.2022 10:20

#include <iostream>

#include <string>

bool is_palindrome(const std::string& s) {

   std::string r(s);

   std::reverse(r.begin(), r.end());

   return s == r;

}

int main() {

   std::string s1,s2;

   setlocale(LC_ALL, "Russian");

   std::cout << "Введите число 1: ";

   std::getline(std::cin, s1);

   std::cout << "Введите число 2: ";

   std::getline(std::cin, s2);

   if (is_palindrome(s1)|| is_palindrome(s2))

       std::cout << "Одно из введенных чисел является палиндромом " << std::endl;

   else

       std::cout << "Ни одно из введенных чисел не является палиндромом " << std::endl;

   return 0;

}

0,0(0 оценок)
Ответ:
vadhmv
vadhmv
23.04.2021 12:25

Однозадачные ОС предоставляют пользователю виртуальную машину и включают средства управления файлами, периферийными устройствами и средства общения с пользователем.

Многозадачные ОС дополнительно управляют разделением между задачами совместно используемых ресурсов.

Многозадачность бывает невытесняющая (NetWare, Windows3/95/98) и вытесняющая (Windows NT, OS/2, UNIX).

В первом случае активный процесс по окончании сам передает управление ОС для выбора из очереди другого процесса.

Во втором — решение о переключении процессора с одного процесса на другой принимает ОС.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота