Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
yarroslawfd
08.04.2021 14:09 •
Информатика
Вводится число n,а затем n чисел.выведите среди n чисел только положительные pascal abs
Показать ответ
Ответ:
vitek03
08.09.2020 07:50
Var
N,i:integer;
begin
readln(n);
for i:=1 to n do
begin
if n>0 then
writeln(i)
end;
end.
0,0
(0 оценок)
Ответ:
bogodist68
08.09.2020 07:50
Program Prog;
Uses crt;
var a: array [1..100] of real;
i, N: integer;
begin
clrscr;
Write('N = ');
readln(n);
for i:=1 to n do
begin
write('a[',i,'] = ');
readln(a[i]);
end;
writeln;
writeln('Положительные числа: ');
for i:=1 to n do
if (a[i]>0) then
writeln('a[',i,'] = ', a[i]);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
А1А2А3А
08.07.2020 11:20
Какой шаблон будет соответствовать поиску файлов, имена которых состоят из 5 символов, начинающихся с символа z, с любым расширением?...
Знания061
08.07.2020 11:20
Сколько слов длины 4, начинающихся с согласной буквы и заканчивающихся гласной буквой, можно составить из букв м, е, т, р, о? буквы могут повторяться....
lenok0701
09.12.2022 23:25
Как сделать, чтобы музыка в презентации играла только на определенном количестве слайдов?...
Katia1717
16.06.2020 14:23
Запиши ключові слова для організації пошуку відомостей за по даними темами; здоровий б життя, музичні традиції рідного краю , найхарактерніші рослини і тварини твоєї...
armanbolat98
16.06.2020 14:23
Продавец зоомагазина уверял покупателя,что купленный им попугай будет повторять каждое услышанное слово. каково же было удивление покупателя,когда он убедился,что...
хамзикош
26.12.2021 04:18
Формула вычитания чисел,хранящиеся в ячейках а1 и в1 будет:...
вопросик70
09.07.2022 09:06
нужны блок схемы по данным ....
TRЮM
01.10.2020 11:01
Дайте краткую характеристику каждому элементу hdd....
тима156
01.10.2020 11:01
Как программируется цикл с предусловием на паскале?...
BOYECH
21.09.2022 12:38
Почему алгоритм вычисления n! должен быть циклическим?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
N,i:integer;
begin
readln(n);
for i:=1 to n do
begin
if n>0 then
writeln(i)
end;
end.
Uses crt;
var a: array [1..100] of real;
i, N: integer;
begin
clrscr;
Write('N = ');
readln(n);
for i:=1 to n do
begin
write('a[',i,'] = ');
readln(a[i]);
end;
writeln;
writeln('Положительные числа: ');
for i:=1 to n do
if (a[i]>0) then
writeln('a[',i,'] = ', a[i]);
end.