В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
angelina2003po
angelina2003po
15.08.2020 15:22 •  Информатика

Вводится массив, состоящий из целых чисел. определите, сколько из них положительные. входные данные сначала задано число n — количество элементов в массиве (1≤n≤35). далее через пробел записаны n чисел — элементы массива. массив состоит из целых чисел. выходные данные необходимо вывести одно целое число — количество положительных элементов массива. примеры ввод вывод 3 1 -2 0 1

Показать ответ
Ответ:
salazarcpt
salazarcpt
06.10.2020 12:51
Program n1;
var n, k, i, c : integer; a:array[0..35] of integer;
begin
  read(N);
  if (N>=1)and(N<=35) then c:=n
  else
    begin
      writeln('error');
      read(N);
    end;
  for i:=1 to c do
    begin
      read(a[i]);
      if A[i]>0 then k:=k+1;
    end;
  writeln(k);
end.

Как то так
программа была скопирована из компилятора и там работала по условию
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота