В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Вводятся два натуральных числа. напишите программу, которая делает то же самое, что и в примерах входных и выходных данных. будьте внимательны, числа и знаки операций разделены пробелами. sample input 1: 2 3 sample output 1: 2 + 3 = 5 sample input 2: 13 8 sample output 2: 13 + 8 = 21 , ! в с++!

Показать ответ
Ответ:
Neuch18
Neuch18
28.01.2023 04:17

Если квадратов десять, то:

 

[если честно, лет 7 не кодил на паскале, поэтому могу ошибаться в синтаксисе или каких-то деталях]

задаем 3 массива числовых элементов:

var

S, P, x: array[1..10] of integer; //S - будущие площади, P - периметры, x - стороны квадратов

i: integer; //счетчик для цикла

 

begin

for i := 1 to 10 do

 begin

  Writeln("Введите сторону "+IntToStr(i)+" квадрата:");

  Readln(x[i]);

 end; //ввели стороны, теперь вычисляем площади и периметры:

 

for i := 1 to 10 do

 begin

  S[i] := x[i]*x[i]; //для нахождения площади перемножаем стороны каждого квадрата

  P[i] := x[i]*4; //для нахождения периметра - умножаем сторону квадрата на 4

//и тут же выводим это на экран:

  Writeln("Площадь "+IntToStr(i)+" квадрата равна "+IntToStr(S[i]));

  Writeln("Периметр "+IntToStr(i)+" квадрата равен "+IntToStr(P[i]));

  Writeln;

 end;

 

Readln //это чтоб дождаться нажатия Энтер перед закрытием окошка :)

end;

 

Должно работать.

0,0(0 оценок)
Ответ:
Артем834
Артем834
16.10.2021 03:26
Задание 1

Нам нужно найти наибольшее число x, при котором данное выражение ложно. Когда оно вообще ложно?

В данном логическом выражении используется дизъюнкция (ИЛИ), которая ложна только в одном случае - это когда оба выражения ложны. Когда же выражения ложны? Рассмотрим же их. В обоих выражениях фигурирует отрицание. То есть, выражение в скобках должны быть истинным. Объясняю:

НЕ (истина) = ложь

А это значит, что условие (x < 10) и (число чётное) должны выполняться. Нам нужно найти наибольшее чётное число. Это не может быть 10, поскольку знак неравенства строгий, следовательно, ближайшее наибольшее чётное число - это 8.

ответ

8

Задание 2

Для данного выражения требуется выполнение следующих условий:

НЕ (x < 7) должно быть ложным, то есть (x < 7) должно быть истинным(x < 6) должно быть ложным

Второе выражение мы можем преобразовать так:

(x ≥ 6). Почему 6 включительно? Потому что, подставив шестёрку в исходное выражение получим: 6 < 6 - ложь. Итого наше выражение имеет вид:

НЕ (x < 7) или (x ≥ 6). Нужно найти наибольшее число, при котором выражение ложно. Это число: 6.

ответ

6

Задание 3

Такое же, как и 2

Задание 4

Решается абсолютно также, как и 2. Дизъюнкция - значит в обеих частях выражения должна быть ложь. Когда ложь получается в двух выражениях? Рассмотрим эти случаи:

НЕ (x < 6) ложно тогда, когда (x < 6) истинно(x < 5) ложно тогда, когда (x ≥ 5)

Итого:

НЕ (x < 6) ИЛИ (x ≥ 5)

ответ

5

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота