В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Вы ввели трехзначное число. затем ввели любое число а. составьте программу, определяющую, равна ли сумма цифр числа задоному числу а контруха по инфе

Показать ответ
Ответ:
nikserg223
nikserg223
23.06.2020 03:57
Var a, b, c, i: integer;
    d: string;
begin
     readln(a, b); 
     d := inttostr(a);
     for i := 1 to length(d) do
         c := c + strtoint(d[i]);
     if (b = c) then writeln('Yes') else writeln('No');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота