В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
uylia144348
uylia144348
10.02.2020 05:16 •  Информатика

Вычислить сумму положительных и произведение отрицательных элементов массива написать программу в паскале

Показать ответ
Ответ:
losp
losp
24.05.2020 11:48

var a: array [1..10] of integer;

      s,s1,i: integer;

begin

  s:=0;

  s1:=1;

  for i:=1 to 10 do 

    begin

      readln(a[i]);

      if a[i]>0 then s:=s+a[i];

      if a[i]<0 then s1:=s1*a[i];

    end;

  writeln('Сумма: ',s,', произведение: ',s1);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота