В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
julietsimms
julietsimms
03.05.2021 13:30 •  Информатика

Вычислить в паскале произведение модулей элементов одномерного массива из 20 чисел, расположенных после первого отрицательного элемента. Входные данные задать самостоятельно.

Показать ответ
Ответ:
vera186
vera186
31.01.2023 15:38

#include <iostream> //подключаем библиотеку iostream

using namespace std;

int main()

{

int a, s; //объявляем целочисленные переменные a и s

cin >> a; //вводим a

s = 0; //обнуляем сумму

 while (a != 0) //цикл while, условие - a не равно нулю

 {

  s = s + a % 10; //остаток от деления числа на 10 - его последняя цифра, прибавляем ее к сумме

  a = a / 10; // убираем последнюю цифру

 }

if (s % 2 == 0) //условие - проверка на четность

{

 cout << "summa chetnaya"; //выводим когда сумма четная

}

else

{

 cout << "summa nechetnaya"; //выводим когда сумма нечетная

}

return 0;

}

0,0(0 оценок)
Ответ:
Aizek111
Aizek111
14.04.2023 05:15

1*25 + 0*24 +1*23 +1*22 + 0*21 + 1*20 = 1*5^2 + 0*2^3 * 3 + 1 * 23 + 1 * 11 * 2 + 0 * 3*7 + 1 * 2^2 * 5. - ЭТО НЕ развёрнутая форма записи числа.  И поэтому НЕЛЬЗЯ определить основание системы счисления. Поэтому записать в краткой форме ЭТО нельзя. Вот если бы была уже указано основание системы счисления, можно было бы выполнить действия и записать краткую форму.

Возможно вы имели в виду 1*2^5 + 0*2^4 +1*2^3 +1*2^2 + 0*2^1 + 1*2^0 и тогда да, ответ предыдущий (101101) верен, но данное задание ответа не имеет.

Объяснение:

развёрнутая форма - цифры числа умножаются на основание системы счисления возведённое в степень по правилу:

показатель степени - место на котором цифра, возводимая в эту степень, должна находится. (крайняя справа - нулевая степень, вторая справа - первая и т.д.)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота