В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Deafandblind
Deafandblind
18.09.2022 06:00 •  Информатика

Выставленные в журнале оценки по контрольной работе образуют массив. составить программу определения числа «5» и «2» , среднего за контрольную. соль в том, что сколько учеников не известно, то есть сам пользователь должен ввести размер массива.

Показать ответ
Ответ:
Marmaladee
Marmaladee
02.03.2020 19:02
Var x,y,z: real;
      t: integer;
begin writeln('введите х и у');
          readln(x,y);
          z:=sqrt(sqr(x)-sqr(y));
          t:=0;
          while (z>0,1) do
          begin t:=t+1;
                    z:=0,98*z;    {если 2% от изменяющегося расстояния до пола;
                   если же имеется ввиду 2% от исходного расстояния,
                   то нужно будет ввести новую переменную
                   или присвоить исходное значение z, например х,
                   то есть сразу после z:=sqrt(sqr(x)-sqr(y)); написать x:=z;
                   Формула (оператор) z:=0,98*z;  изменится так:
                   z:=z-x*0,98}
           end;
          writeln('палка упадет через ', t,' мин.');
end.
0,0(0 оценок)
Ответ:
динозаврррррр
динозаврррррр
06.12.2021 22:55

Держи. На питоне

Объяснение:

n = int(input())

cool_score = 0

jumps = input().split()

sorted_jumps = sorted(jumps)

for i in range(len(jumps)):

   if i != len(jumps) - 1:

       Ni = jumps.index(sorted_jumps[i]) + 1

       Hi = sorted_jumps[i]

       if jumps.count(jumps[i]) > 1:

           jumps[i] = 'done'

       Nj = jumps.index(sorted_jumps[i + 1]) + 1

       Hj = sorted_jumps[i + 1]

       a = 'abs({} - {}) + {} - {}'.format(int(Ni), int(Nj), int(Hj), int(Hi))

       cool_score += eval(a)

print(cool_score)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота