В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
DigroTube
DigroTube
06.09.2022 04:04 •  Информатика

Выведите все элементы массива с: а) нечётными индексами (то есть A[1], A[3], A[5], ...);

б) чётными индексами (то есть A[0], A[2], A[4], ...).

Формат входных данных

Вводится количество элементов в массиве. Далее вводятся элементы массива.

Формат выходных данных

Выведите ответ на задачу.

Sample Input:

5

1

2

3

4

5

Sample Output:

1 3 5

Показать ответ
Ответ:
sveta17032001
sveta17032001
22.12.2020 23:42

int[] mas;

int n;  

n = Convert.ToInt32(Console.ReadLine());

mas = new int[n];

for (int i = 0; i < mas.Length; i++)

mas[i] = Convert.ToInt32(Console.ReadLine());

Console.WriteLine();

Console.WriteLine("Элементы с чётными индексами:");

for (int i = 0; i < mas.Length; i = i + 2)

{    

Console.WriteLine(mas[i]);

}

Console.WriteLine();

Console.WriteLine("Элементы с нечётными индексами:");

for (int i = 1; i < mas.Length; i = i + 2)

{

Console.WriteLine(mas[i]);

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота