В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ibondarenk2013
ibondarenk2013
07.10.2020 14:28 •  Информатика

Вывести элементы массива значения которых меньше их индекса. составить программу (паскаль), оформить ответ!

Показать ответ
Ответ:
peindragneel11
peindragneel11
25.08.2020 10:56
Var  a: array[1..10] of integer;  i: integer;
begin 
Writeln('Массив '); 
for i := 1 to 10 do  begin   
  a[i] := random(10);   
  write(a[i], ' '); 
end; 
Writeln; 
writeln('Числа и их индекс (по условию)'); 
for i := 1 to 10 do   
if i > a[i] then write('(', a[i], ' - ', i, ') ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота