Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Denis12121210
05.09.2021 18:02 •
Информатика
Вывести квадраты чисел от 1 до n. в паскале написать программу (не используя for)
Показать ответ
Ответ:
bigrushnboss
08.10.2020 05:40
1)
// PascalABC.NET 3.3
begin
var n:=ReadInteger('n =');
Range(1,n).Select(i->i*i).Println;
end.
Пример:
n = 5
1 4 9 16 25
2)
var n,i: integer;
begin
write('N = ');
readln(n);
i:=0;
while (i<n) do
begin
i:=i+1;
write(i*i,' ');
end;
end.
3)
var n,i: integer;
begin
write('N = ');
readln(n);
i:=0;
repeat
i:=i+1;
write(i*i,' ');
until i=n;
end.
Пример:
N = 5
1 4 9 16 25
0,0
(0 оценок)
Популярные вопросы: Информатика
pavlushkaaa
07.03.2020 04:38
В ячейке Microsoft Excel А1 необходимо рассчитать сумму содержимого ячеек С1 и В1 для этого в ячейке А1 нужно указать: а)С1+В1; б)СУММ(С1:В1); в)=С1+В1; г)=СУММ(С1+В1); д) ни одно...
Andrey1privet4
04.11.2022 10:16
НАПИШИТЕ СКРИПТ Сума арифметической прогресии [2,5,8,11,14,...] В...
НЕВЕСОМАЯ67
19.02.2020 07:07
10. Параметр «master» отвечает за указание ссылки на контейнер (окно). Для приложений, состоящих из одного окна, этот параметр необязателенСодержит набор опций, которые указываются...
Lenakorzyn
27.05.2020 15:04
2- 1. реакция гидролиза kcns, определить среду, расписать 2. cuj2 = cuj + j2 - окислительно-восстановительная реакция, заранее...
тима2011
27.05.2020 15:04
Раскройте скобки,поставив глаголы в нужном времени. 1mike is in the library.he (read) a book in the reading room. 2where(be)tom? i(not/see)him. 3 i(not/understand)what he(speak)about....
shvok
27.05.2020 15:04
Отгадай загадку с и недолго сделать кошке если есть сметана в плошке с е же делать нелегко коль забрался высоко...
муслима18
27.05.2020 15:04
Установите соответствие между схемой реакции и формулой окислителя в ней схема реакции а) so2 + o2 → so3 в) so2 + h2s→ s + h2o в) so2 + cl2 → so2cl2 г) k2so3 → k2s + k2so4 формула...
Luna013
27.05.2020 15:04
Найдите значение выражения a^12*(a^-4)^4, при а=-1/2...
karina845
27.05.2020 15:04
Можно вырасти среди животных. в 15-40 предложеиях...
innocen
27.05.2020 15:04
Какой из следующих факторов не является причиной возникновения силы трения? а) взаимное притяжения молекул соприкасающихся тел б) скольжение одного тела по поверхности другого в) шероховатость...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
// PascalABC.NET 3.3
begin
var n:=ReadInteger('n =');
Range(1,n).Select(i->i*i).Println;
end.
Пример:
n = 5
1 4 9 16 25
2)
var n,i: integer;
begin
write('N = ');
readln(n);
i:=0;
while (i<n) do
begin
i:=i+1;
write(i*i,' ');
end;
end.
3)
var n,i: integer;
begin
write('N = ');
readln(n);
i:=0;
repeat
i:=i+1;
write(i*i,' ');
until i=n;
end.
Пример:
N = 5
1 4 9 16 25