В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
temaghj2
temaghj2
14.02.2021 04:54 •  Информатика

Write a Python program that uses a ‘FOR’ loop to print ‘Red’ and then ‘Gold’ 20 times all on separate lines.

Red

Gold

Red

Gold

Напишите программу Python, которая использует цикл " FOR " для печати ‘Красный", а затем "Золотой" 20 раз все на отдельных линиях.

Красный

Золото

Красный

Золото​

Показать ответ
Ответ:
fifi17
fifi17
02.10.2020 20:20
В операторах Dat[1] := 7; ... ; Dat[10] := 9; задаются элементы массива.
m := 0; n := 0; - начальные значения переменных m и n.
В цикле for k := 1 to 10 do ... каждый элемент массива сравнивается с текущим значением переменной m (Dat[k] >= m). Если элемент больше, то значения переменных m и n меняются: в переменной m запоминается значение элемента массива, в переменной n - значение номера (индекс) этого элемента. Таким образом, после выполнения цикла значения переменных будут: m=10; n=8. На экран будет выведено значение 8 (это номер последнего максимального элемента массива).
ответ: 8
0,0(0 оценок)
Ответ:
JoyGames14982
JoyGames14982
17.08.2022 03:26
C#. Код ниже.

using System;
namespace ConsoleApp1{    class Program    {        static void Main(string[] args)        {            //переменная для хранения суммы, изначально = 0            var sum = 0;            //вводимое число, изначально = 0            int number = -1;            //пока число не равно 0            while (number != 0)            {                //выводим сообщение с ввести число                Console.Write("Введите число: ");                //вводим число                number = int.Parse(Console.ReadLine());                //суммуируем                sum += number;            }            //Выводим результат            Console.WriteLine("Выход из цикла. Сумма = " + sum);            Console.ReadKey();        }    }}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота