В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
lholkina
lholkina
27.10.2022 21:54 •  Информатика

Яп Python 3 Спам карается баном.

Создать программу регистрации подписчиков журнала, в которой создается база данных, содержащая Ф.И.О., название журнала, номер квитанции, сумму оплаты, срок подписки. Программа должна предоставлять возможность просматривать, добавлять, удалять, поиска, хранить данные.

Показать ответ
Ответ:
Анжеkf23
Анжеkf23
08.01.2020 05:46

Пример работы на рисунке 1.

Код:

#include <iostream>

#include <clocale>

#include <string>

using namespace std;


int main() {

setlocale(LC_ALL, "Russian");


//Входные данные

int K = 43;


if(K < 1 || K > 365) {

 cout << "Неверные входные данные";

 return 1;

}

// Дни

string Days[] = { "Понедельник", "Вторник", "Среда", "Четверг", "Пятница", "Суббота", "Воскресение" };

int N = K % 7;

cout << "День года №" << K << " называется " << Days[N] << endl;

system("pause");

return 0;

}


Вс++ дни недели пронумерованы следующим образом: 1- понедельник, 2 -вторник, ..6-суббота, 7 - воскре
0,0(0 оценок)
Ответ:
OtlicnikKZ1337
OtlicnikKZ1337
28.08.2020 04:34

Программа представленна ниже. Скриншот с результатами исполнения в приложениях.


#include <iostream>//cin

#include <cstdlib> //rand()

#include <algorithm>//sort()

#include <ctime>//time()

using namespace std;


#define N 5 // Количество элементов в массиве


bool moreThen(int a, int b) {

return ( a > b );

}


int main() {

int Arr[N];

srand(static_cast<unsigned int>(time(0))); //Инициализация генератора случайных чисел

cout << "Исходный массив: ";

for(int i = 0; i < N; ++i){

 Arr[i] = -rand(); //Заполнение случайными числами

 cout << Arr[i] << " ";

}

cout << endl;

cout << "Отсортированный массив: ";

sort(Arr, Arr+N, moreThen); //Сортировка с использованием stl

for(int i = 0; i < N; ++i){

 cout << Arr[i] << " ";

}

cout << endl;

return 0;

}


Отсортировать массив, состоящий из отрицательных чисел. (выберу лучший ответ, +60 ) на c++. 7 поясне
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота