В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
zhasmin777123
zhasmin777123
22.02.2021 08:10 •  Информатика

yапиши программу которая выводит на экран значения функции y=f(x)аргументы x прнимает значения от x1 до x2 с шагом (дельта)x


yапиши программу которая выводит на экран значения функции y=f(x)аргументы x прнимает значения от x1

Показать ответ
Ответ:
Darynaost
Darynaost
01.04.2022 00:21

#include <iostream>

#include <cstdlib>

#include <ctime>

#include <vector>

#include <algorithm>

using namespace std;

int main() {

vector<int> arr;

int size, min(9999999), sum(0);

cout << "N: ";

cin >> size;

for (int i = 0; i < size; ++i) {

 int temp;

 cout << "Element #" << i + 1 << ": ";

 cin >> temp;

 arr.push_back(temp);

 if (temp >= 0 && temp < min) {

  min = temp;

 }

 if ((i + 1) % 2 == 0) { // нумеруем элементы с 1

  sum += temp;

 }

}

cout << "Min: " << min << endl;

cout << "Sum: " << sum << endl;

for (int i = arr.size()-1; i>=0; --i) {

 cout << arr[i] << " ";

}

}


Нужно написать программу на c++ 15. Дан одномерный массив, состоящий из N вещественных элементов. 15
0,0(0 оценок)
Ответ:
fuvgkvu
fuvgkvu
02.06.2021 14:52

#include <iostream>

#include <cstdlib>

#include <ctime>

#include <vector>

#include <algorithm>

using namespace std;

int main() {

vector< vector<int> > arr;

arr.resize(8);

for (int i = 0; i < 8; ++i) {

 arr[i].resize(7);

}

for (int i = 0; i < 8; ++i) {

 for (int j = 0; j < 7; ++j) {

  arr[i][j] = rand();

  cout << arr[i][j] << " ";

  if (j == 6) {

   cout << endl;

  }

  }

}

swap(arr[3], arr[0]);

swap(arr[4], arr[7]);

cout << endl;

for (int i = 0; i < 8; ++i) {

 for (int j = 0; j < 7; ++j) {

  cout << arr[i][j] << " ";

  if (j == 6) {

   cout << endl;

  }

 }

}

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота