В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
zubayr3
zubayr3
14.08.2021 12:04 •  Информатика

Язык Pascal. Напишите программу, которая позволяет вводить с клавиатуры 4-значное число и определять, является ли число счастливым или нет. Счастливое число — это такое, у
которого сумма первых двух цифр равна сумме двух последних. Например, число 1230 —
счастливое, а 1234 — нет.
На вход программы подаётся четырёхзначное натуральное число (проверку корректности
ввода проводить не надо), на выходе должно появиться одно слово - Yes (с заглавной
буквы!), если число счастливое, и No, если нет.​


Язык Pascal. Напишите программу, которая позволяет вводить с клавиатуры 4-значное число и определять

Показать ответ
Ответ:
Макушка007
Макушка007
29.04.2021 10:38

var A,s1,s2: integer;

begin

   write('Введите число: '); readln(A);

   

   s1 := (A div 1000) + (A div 100) mod 10;

   s2 := (A div 10) mod 10 + A mod 10;

   

   if s1 = s2 then writeln('Yes')

   else writeln('No');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота