В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
anna1082002
anna1082002
03.10.2020 23:11 •  Информатика

Язык паскаль, можно через while написать программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор пока не будет введён ноль) и подсчёт суммы введённых положительных чисел. используйте оператор repeat

Показать ответ
Ответ:
pilizaveta13
pilizaveta13
12.06.2020 20:58

Объяснение:

Pascal

var a,i,s,n:integer;

begin

 s:=0;

 n:=0;

 repeat

    readln(a);

    if a>0 then begin

       n:=n+1;

       s:=s+a;

    end;

 until a = 0;

 writeln('Сумма ',s:5,'  Среднее арифметическое ',s/n);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота