В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
wartander595
wartander595
20.02.2022 10:31 •  Информатика

Язык Паскаль. Напишите программу, которая моделирует работу следующего автомата. Автомат получает на вход трехзначное число и строит новое число следующим образом: 1) вычисляются суммы первой и второй, затем - второй и третьей цифр; 2) эти суммы записываются в порядке не возрастания. Например, для числа 639 получаем суммы: 6 + 3 = 9; 3 + 9 = 12. Результат: 129 Напишите программу, которая реализует работу данного автомата

Показать ответ
Ответ:
404ada505
404ada505
28.03.2021 12:29

var N,a,b,c,s1,s2:integer;

begin

Writeln('Напишите трёхзначное число');

ReadLn(N);

a:= N div 100;

b:= N div 10 mod 10;

c:= N mod 10;

s1:= a+b;

s2:= b+c;

if s1<s2 then

write(s2,s1)

else

write(s1,s2);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота