В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Палина200413
Палина200413
21.05.2022 01:12 •  Информатика

ЯЗЫК ПАСКАЛЬ

ПАША И КУБИКИ
У маленького Паши было 5 кубиков с цифрами от 1 до 5 на каждом кубике. В не самый прекрасный день Паша обнаружил, что один из кубиков потерялся.
Паше понять, кубик с какой цифрой потерян, зная цифры на оставшихся кубиках. Формат входных данных: Программе на вход подаются 4 числа-цифры на оставшихся кубиках.
Формат выходных данных: Программа должна вывести одно число -цифру на кубике, который потерялся.​

Показать ответ
Ответ:
daniilnz1
daniilnz1
14.02.2021 13:12

program Chernovik;

var a,b,c,d,i: integer;

begin

read(a,b,c,d);

for i:=1 to 5 do

if (i<>a) and (i<>b) and (i<>c) and (i<>d) then write(i)

end.

Объяснение:

Вводим числа

В цикле проверяем условие, если переменная цикла не равна ни одному из введенных чисел, то выводим её на экран

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота