В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
victoria223
victoria223
28.06.2021 13:20 •  Информатика

язык питон
1) Сколько раз будет выполнено тело цикла?​

а) for i in range(15): s = s + 1​

б) for i in range(10, 15): s = s + 1​

в) for i in range(-1, 1): s = s + 1​

г) for i in range(1, 1): s = s + 1​

д) k = 5​

for i in range(k-1, k+1): s = s + 1
2)
Напишите программу, которая вычисляет сумму:

а) первых n натуральных чисел;

б) квадратов первых n натуральных чисел;

в) всех чётных чисел в диапазоне от 1 до n;

г) всех двузначных чисел.

Показать ответ
Ответ:
skyline12345
skyline12345
22.02.2021 18:47

ответ:

алгоритм- это конечная совокупность точно заданных правил решения произвольного класса или набор инструкций, описывающих порядок действий исполнителя для решения некоторой . в старой трактовке вместо слова «порядок» использовалось слово «последовательность», но по мере развития параллельности в работе компьютеров слово «последовательность» стали заменять более общим словом «порядок». независимые инструкции могут выполняться в произвольном порядке, параллельно, если это позволяют используемые исполнители.

ранее в языке писали «алгорифм», сейчас такое написание используется редко, но, тем не менее, имеет место исключение (нормальный алгорифм маркова).

часто в качестве исполнителя выступает компьютер, но понятие алгоритма необязательно относится к компьютерным программам, так, например, чётко описанный рецепт приготовления блюда также является алгоритмом, в таком случае исполнителем является человек (а может быть и некоторый механизм, ткацкий станок, и

можно выделить алгоритмы вычислительные (о них в основном идет далее речь), и . вычислительные по сути преобразуют некоторые начальные данные в выходные, реализуя вычисление некоторой функции. семантика алгоритмов существенным образом может отличаться и сводиться к выдаче необходимых воздействий либо в заданные моменты времени, либо в качестве реакции на внешние события (в этом случае, в отличие от вычислительного алгоритма, может оставаться корректным при бесконечном выполнении).

понятие алгоритма относится к первоначальным, основным, базисным понятиям . вычислительные процессы алгоритмического характера (арифметические действия над целыми числами, нахождение наибольшего общего делителя двух чисел и т. д.) известны человечеству с глубокой древности. однако в явном виде понятие алгоритма сформировалось лишь в начале xx века.

0,0(0 оценок)
Ответ:
Someoneone
Someoneone
29.09.2021 04:09
Var a, b: integer;
var c: string;
begin
writeln('Введите 1 число.');
readln(a);
writeln('Введите 2 число.');
readln(b);
writeln('Знак операции.');
readln(c);
if c='*' then writeln(a*b);
if c='/' then writeln(a/b);
if c='-' then writeln(a-b);
if c='+' then writeln(a+b);
end.
2 ЗАДАЧА 
var a, b: real;
begin
writeln('Зарабаток Пети:');
readln(a);
writeln('Зарабаток Петрова:');
readln(b);
if a>b then writeln('Петя заработал больше Петрова.')
else if a=b then writeln('Петров и Петя заработали одинаково.')
else
writeln('Петров заработал больше Пети.');
writeln('Среднее: ', (a+b)/2);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота