В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Easy11111
Easy11111
13.08.2020 07:52 •  Информатика

Язык питон A. Петины Финансы
Ограничение времени:1 секунда

Ограничение памяти:64Mb

Ввод:finance.in

Вывод:finance.out

Петя решил организовать учет своих денежных трат в течение двух первых недель месяца. Для этого он по итогам каждого дня записывал в блокнот день и сумму в рублях, затраченную в этот день. Напишите программу, определяющую какую самую маленькую сумму за один день истратил Петя.

Формат ввода

Входной файл finance.in содержит 14 строк - по одной на каждый день. После каждого номера дня через пробел следует целое неотрицательное число, не превышающее 5000. Это сумма в рублях, затраченная Петей за день.

Формат вывода:В файл finance.out выведите ответ к задаче.

Показать ответ
Ответ:
licicha
licicha
02.04.2023 01:09

ответ:Решение. 1. A=m*g*H; H=0,5*g*t^2; A=0,5*m*(g*t)^2. m=1; t=5; g=10.

2. F=k*x0; E=0,5*k*x^2; k=F/x0; E=0,5*(F/x0)*x^2; F=3*10^4; x0=10^-2; x=5*10^-2;

3. v=v0-g*t; Ek=0,5*m*v^2; Ek0=0,5*m*v0^2; En=Ek0-Ek; m=0.05; t=2; v0=30; t=2.

4. H=0,5*g*t^2; En1=m*g*0,5*H; Ek1=En1; m=5; t=2; (Задача не совсем понятна! 2 секунды-это общее время падения на Землю, или время падения до выбранной точки? Я подсчитал, как общее время падения!) .

5. m*g*H+0,5*m*V0^2=E; m=E/( g*H+0,5*V0^2); V=(V0^2+2*g*H)^0,5; V0=10; H=75; E=1,6*10^3; g=10.

Объяснение:

0,0(0 оценок)
Ответ:
vasnecovadaha
vasnecovadaha
08.10.2022 12:23

uses crt;

const raz=[' ','.',',','?','!'];{/разделители слов, можно добавить}

var s,sl:string;

   i,k:byte;

begin

clrscr;

writeln('Строка:');

readln(s);

writeln('Слово:');

readln(sl);

k:=0;

for i:=1 to length(s) do{идем по строке}

if(s[i]=sl[1])and((s[i-1] in raz)or(i=1)){если символ равен первому символу слова

а перед ним разделитель или начало строки}

and((s[i+length(sl)] in raz)or(i+length(sl)=length(s))){и после слова разделитетль или конец строки}

and(copy(s,i,length(sl))=sl){и все буквы на интервале равны слову}

then k:=k+1;{считаем}

write('Слово ',sl,' встречается ',k,' рз.');

readln

end.

Объяснение:

на каком языке? (В ответе паскаль)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота