В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
бабуся3
бабуся3
19.05.2023 07:42 •  Информатика

ЯЗЫК ПИТОН А) Требуется написать программу, которая вводит натуральное число N. Затем поочередно вводит N натуральных чисел в список и находит количество чисел, делящихся на 11, но не делящихся на 4.    

В) Требуется написать программу, которая вводит натуральное число N. Затем поочередно вводит N натуральных чисел в список и находит количество чисел, оканчивающихся на цифру 0 или на цифру 5.    

С) Напишите программу, которая вводит натуральные числа (их количество неизвестно, но известно, что в конце вводимой последовательности стоит 0) в список и находит количество чисел кратных 8, но не кратных 3.    

D) Напишите программу, которая вводит натуральные числа (их количество неизвестно, но известно, что в конце вводимой последовательности стоит 0) в список и находит количество четных чисел или чисел оканчивающихся на цифру 7.

Показать ответ
Ответ:
Partners04
Partners04
22.02.2022 03:33

1. Назовите составные части компьютера.

2. Какую функцию выполняет процессор?

Процессор - центральное устройство компьютера. Назначение процессора: 1) управлять работой ЭВМ по заданной программе; 2) выполнять операции обработки информации.

3. Для чего используется оперативная память?

Оперативная память нужна для работы системных процессов в режиме реального времени: браузера, почтовых клиентов, офисных приложений, компьютерных игр и так далее. Она вторая по скорости работы в системе — ОЗУ идет сразу после кэша процессора или, как его еще называют, сверхоперативной памяти.

4. Приведите примеры устройств ввода и вывода.

Устройства ввода

Клавиатура

Мышь и тачпад

Планшет

Джойстик

Сканер

Цифровые фото, видеокамеры, веб-камеры

Микрофон

Устройства вывода

Монитор (дисплей)

Принтер

Графопостроитель (плоттер)

Проектор

5. Что такое порт?

Порт - это числовой идентификатор программы или процесса, которые обслуживают сетевые соединения на заданном сетевом адресе (IP-адресе).

6. Что такое материнская плата?

Печатная плата, являющаяся основой построения модульного устройства, например — компьютера.

Системная плата содержит основную часть устройства, дополнительные же или взаимозаменяемые платы называются платами расширений.

7. Какую функцию выполняет системная шина?

Компьютерная ши́на (англ. computer bus) в архитектуре компьютера — соединение, служащее для передачи данных между функциональными блоками компьютера. В отличие от соединения точка-точка, к шине обычно можно подключить несколько устройств по одному набору проводников.

Объяснение:

0,0(0 оценок)
Ответ:
elizawetailjin
elizawetailjin
28.04.2020 22:37
//Я так понял, что нужно объеденить 2 массива в 1 большой. Если же нужно, чтобы каждый элемент третьего массива состоял из суммы элементов с такии же индексом двух предыдущих массивов, то нужен другой код

Program Test;

const Size = 5; x = 1; y = 10;

Var i, j, Entered: integer; Arr1: array[1..Size] of integer; Arr2: array[1..Size] of integer; Arr3: array[1..Size * 2] of integer;

Begin

Randomize;

j := 0;

for i := 1 to Size do
begin
Arr1[i] := Random(x, y);
Arr2[i] := Random(x, y);
end;

for i := 1 to Size * 2 do
begin
if (i <= Size) then
Arr3[i] := Arr1[i]

else
begin
j := j + 1;
Arr3[i] := Arr2[j];
end;
end;

Write('Показать 1 массив? Если да, то введи 1: ');
Readln(Entered);

if (Entered = 1) then
begin
Writeln();

for i := 1 to Size do
Writeln('Элемент ', i, ' = ', Arr1[i]);
end;

Writeln();
Entered := 0;

Write('Показать 2 массив? Если да, то введи 2: ');
Readln(Entered);

if (Entered = 2) then
begin
Writeln();

for i := 1 to Size do
Writeln('Элемент ', i, ' = ', Arr2[i]);
end;

Writeln();
Writeln('Суммарный массив:');
Writeln();

for i := 1 to Size * 2 do
Writeln('Элемент ', i, ' = ', Arr3[i]);

End.
Нужно составить прогораму. даны два массива сформированных случайным образом, составить программу ко
Нужно составить прогораму. даны два массива сформированных случайным образом, составить программу ко
Нужно составить прогораму. даны два массива сформированных случайным образом, составить программу ко
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота