В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
lolEzzGG
lolEzzGG
17.02.2021 16:31 •  Информатика

язык Питон
Задача 1. Язык математики
Что нужно сделать
Маше для защиты курсовой работы нужно написать программу для расчёта экономической модели по формуле. Как записать саму формулу в программу, она не знает, у неё есть только начальные значения. Поэтому Маша решила просто заплатить Егору, чтобы тот написал её быстрее.
Дана программа:

a = 8
b = 10
c = 12
d = 18

Продолжите программу: переведите выражение с математического языка на язык Python, запишите его в переменную res и выведите результат.

Выражение: документ

Что оценивается
• Результат вычисления корректен.
• Правильное употребление пробелов после запятых и при бинарных операциях.

Показать ответ
Ответ:
salgis
salgis
23.02.2021 18:55
Задание 1 во вложении.

Задание2.

const
  m = 20;{максимальное количество элементов}

var
  a: array[1..m] of real;
  i, n: integer;

begin
  Write('Введите количество элементов (от 1 до 20): ');
  Readln(n);
  Writeln('Вводите через пробел элементы массива');
  for i := 1 to n do
  begin
    Read(a[i]);
    a[i] := sqr(a[i])
  end;
  Writeln('Результирующий массив:');
  for i := 1 to n do Write(a[i]:0:4, ' ');
  Writeln
end.

Тестовое решение:

Введите количество элементов (от 1 до 20): 5
Вводите через пробел элементы массива
1.3 2.7 -4 4.23 0
Результирующий массив:
1.6900 7.2900 16.0000 17.8929 0.0000
0,0(0 оценок)
Ответ:
KatyshaMarina
KatyshaMarina
20.01.2020 16:56
1.
#include <iostream>
using namespace std;

int main()
{
    int a, b;
    cout << "a = ", cin >> a;
    cout << "b = ", cin >> b;
    for (int i=a; i<=b; i++) {
    cout << i << " ";
    }
    return 0;
}

Пример:
a = 5
b = 12
5 6 7 8 9 10 11 12

2.
#include <iostream>
using namespace std;

int main()
{
    int a, b, s=0;
    long long p=1;
    cout << "a = ", cin >> a;
    cout << "b = ", cin >> b;
    for (int i=a; i<=b; i++) {
    p = p*i;
    s = s+i;
    }
    cout << "p = " << p << " s = " << s;
    return 0;
}

Пример:
a = 5
b = 12
p = 19958400 s = 68
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота