В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
DirolFix
DirolFix
09.03.2022 11:05 •  Информатика

Язык программирования C++
Задача 1.
Задан двухмерный массив B[4][4]. Составить программу, которая организует двумерный массив, элементы главной диагонали которого равны соответствующим элементам исходного массива, а остальные элементы равны нулю.
Задача 2.
Вывести на экран элементы побочной диагонали (вывод организовать по диагонали).​

Показать ответ
Ответ:
max698
max698
07.05.2022 21:24
Var mas:array[1..100,1..100] of integer; 
           N,M,D,N2,i,C,j,M2,k:integer; 
begin
N:=0;D:=0;k:=0;
write('Введите N = ');Readln(N);
write('Введите M = ');Readln(M);  
For i:= 1 to M do begin         
     M2:=1;        
        For N2:=i downto 1 do begin                 
                 if M2<=N then begin         
                       mas[M2,N2]:=k;                   
                       k:=k+1;                 
                       M2:=M2+1;          
                  end;            
               end;   
        end;          
 //после побочной диагонали    
For D:=2 to N do begin   
      M2:=D;         
              For N2:=M downto 1 do begin                  
                    IF (M2<=N) and (N2<=M) then begin           
                              mas[M2,N2]:=k;                   
                              k:=k+1;                   
                            M2:=M2+1;                
                     end;         
           end;         
end;       
    For i:=1 to N do begin Writeln();         
           for j:=1 to M do                
          write(mas[i,j],'    ');    
       end;  
end.
0,0(0 оценок)
Ответ:
unknown2015
unknown2015
12.04.2021 12:46
//Dev C++ 4.9.9.2
//Знаю, что старьё

//1
#include <iostream>
#include <ctime>
#include <cstdlib>
using namespace std;

int main(){
 srand ( time(NULL) );
  int ar[10];
 int k;
 k=0;
 for(int i=0;i<10;i++){
         ar[i]=rand()%10-3;
         cout<<ar[i]<<endl;
         if((ar[i]%2==0) && (ar[i]>0))
          k++;
          }
 cout<<"Result:"<<k;
 cin.get();
 cin.get();
 return 0;
   }

//2
#include <iostream>
#include <ctime>
#include <cstdlib>
using namespace std;

int main(){
 srand ( time(NULL) );
  int ar[10];
 int k1,k2;
 double r1,r2;
 k1=0;
 k2=0;
 r1=0;
 r2=0;
 for(int i=0;i<10;i++){
         ar[i]=rand()%100;
         cout<<ar[i]<<endl;
         if(ar[i]<10){
          k1++;
          r1=r1+ar[i];} else {
          k2++;
          r2=r2+ar[i];
          }
          }
 r1=r1/k1;
 r2=r2/k2;
 cout<<"<10: "<<r1<<endl;
 cout<<">=10: "<<r2<<endl;
 cin.get(); 
 cin.get();
 return 0;
   }
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота